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How to install loT Headless image on RPi3 (for ubuntu)
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How to install loT Headless image on RPi3 (for ubuntu) SOSCON

1. Downloads a script that can install the image of tizen platform on the SD card.

* rpi_sdcard_setup.sh

$ wget https://qgit.tizen.org/cgit/apps/native/position-finder-client/plain/tool/rpi sdcard setup.sh
$ chmod +x rpi_sdcard_setup.sh

* You can also go to the location where the script is located and download it.
— Clones position-finder-client repository with Git Bash.
$ qit clone git://git.tizen.org/apps/native/position-finder-client (Branch : template)
— The script(rpi_sdcard_setup.sh) is located in the position-finder-client/toolsdirectory.

$ cd position-finder-client/tools/
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How to install loT Headless image on RPi3 (for ubuntu) SOSCON

2. Runs the downloaded script on the SD card.

1. Inserts SD card reader with an SD card into the PC,

2. Runs the script.
$ ./rpi_sdcard_setup.sh

3. There are three questions when the script runs.

#1: Please type device node of usb [press enter key to use default(sdb)] :

#2 : Please type binary version of tizen [press enter key to use default(latest)]

When you press enter, latest binary is downloaded. If you want another version, please enter the desired versi
on date. (e.g. 20171020.3)

Information about the version can be found on http://download.tizen.org/snapshots/tizen/4.0-unified/
#3: /dev/sdb will be formatted, Is it OK? [y/n]
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What the script(rpi_sdcard_setup.sh) does SOSCON

Downloading files needed for image installation
Downloading the loT Headless Image

Making partitions of SD Card

Fusing boot & platform image to SD Card
Copying firmwares for Wi-Fi and Bluetooth

U WS

* NOTE : The above should be done on Ubuntu PC,

TIZEN PLATFORM



1. Downloading files needed for image installation SOSCON

1. Installing pv package on Ubuntu PC.

$ sudo apt-get install pv

2. Downloading the fusing-script for RPi3.

$ wget https://git.tizen.org/cgit/platform/kernel/linux-
rpi3/plain/scripts/sd_fusing_rpi3.sh?h=submit/tizen/20170725.223437 --output-document=$download_dir/$script_fusing

3. Downloading firmwares for Wi-Fi and Bluetooth.

$ wget https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcmn80211/brcm/brcmfmac43430-sdio.bin
$ wget https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm80211/brcm/bremfmac43430-sdio. txt
$ wget https://github.com/OpenELEC/misc-firmware/raw/master/firmware/brcm/BCM43430A1.hcd
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2. Downloading the loT Headless Image SOSCON

*  Kernel & Module Image

Access http://download tizen.org/snapshots/tizen/unified/latest/images/standard/iot-boot-arm64-rpi3/
Download tizen-unified_2017xxx.x_iot-boot-arm64-rpi3.tar.gz

* Tizen Platform Image

Access http://download.tizen.org/snapshots/tizen/unified/latest/images/standard/iot-headless-2parts-armv7|-rpi3/
Download tizen-unified_2017xxxx.x_iot-headless-2parts-armv7I-rpi3.tar.gz

3. Making partitions of SD Card

1. Check the device node of SD card. (ex. sdx : x is alphabet)
2. Make partitions using the fusing-script.*

$ sudo ./sd_fusing_rpi3.sh -d /dev/sdb --format
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Raspberry Pi3 downloader, version 0.1

et e Screen when SD Card is formatted .*
/dev/sdb will be formatted, Is it O0K? [y/n]

Y

Start /dev/sdb format

Label dev size
boot /dev/sdbl 64 MB
rootfs /dev/sdb2 3072 MB
system-data /dev/sdb3 512 MB
[Extend] /dev/sdb4

user /dev/sdb5 26848 MB
modules /dev/sdb6 20 MB
ramdisk /dev/sdb7 8 MB

Remove partition table...

16+0 records in

16+0 records out

8192 bytes (8.2 kB) copied, 0.22686 s, 36.1 kB/s
Checking that no-one is using this disk right now ...
0K

Disk /dev/sdb: 30528 cylinders, 64 heads, 32 sectors/track

sfdisk: ERROR: sector O does not have an msdos signature

/dev/sdb: unrecognized partition table type

0ld situation:

No partitions found

New situation:

Units = mebibytes of 1048576 bytes, blocks of 1824 bytes, counting from @

Device Boot Start End MiB #blocks Id System

/dev/sdbl " 4 67 64 65536 e W95 FAT16 (LBA)
/dev/sdb2 68 3139 3072 3145728 83 Linux
/dev/sdb3 3140 3651 512 524288 83 Linux
/dev/sdb4 3652 30527 26876 27521024 5 Extended
/dev/sdb5 3652+ 30499 26848- 27492351+ 83 Linux
/dev/sdb6 30500+ 30519 20- 20479+ 83 Linux
/dev/sdb7 30520+ 30527 8- 8191+ 83 Linux

Successfully wrote the new partition table
Re-reading the partition table ...

If you created or changed a DOS partition, /dev/foo7, say, then use dd(1)

to zero the first 512 bytes: dd if=/dev/zero of=/dev/foo7 bs=512 count=1

(See fdisk(8).)

mkfs.fat 3.0.26 (2014-03-07)

mkfs.fat: warning - lowercase labels might not work properly with DOS or Windows
End /dev/sdb format



4. Fusing boot & platform image to SD Card SOSCON

1. Write boot image to SD Card using the fusing-script.*
$ sudo ./sd_fusing_rpi3.sh -d /dev/sdb -b tizen-unified_2017xxxx.x_iot-boot-arm64-rpi3.tar.gz

2. Write loT Headless image to SD Card using the fusing-script.*
$ sudo ./sd_fusing_rpi3.sh -d /dev/sdb -b tizen-unified_2017xxxx.x_iot-headless-2parts-armv7I-rpi3.tar.gz

5. Copying firmwares for Wi-Fi and Bluetooth

Copy firmwares for Wi-Fi and Bluetooth to SD Card

$ mkdir rootfs

$ sudo mount /dev/sdb2 rootfs

$ sudo mkdir -p rootfs/usr/etc/bluetooth

$ sudo cp BCM43430A1.hcd rootfs/usr/etc/bluetooth

$ sudo mkdir -p rootfs/usr/lib/firmware/brcm

$ sudo cp brcmfmac43430-sdio.* rootfs/usr/lib/firmware/brcm
$ sync

$ sudo umount rootfs

$ rmdir rootfs



SOSCON

Raspberry Pi3 downloader, version 0.1

Fusing binary: Screen when boot image is installed . *

tizen-unified 20170814.1 common-boot-armé4-rpi3.tar.gz

modules.img
boot.img

[Fusing boot.img]
umount: /dev/sdbl: not mounted
65536+0 records in81MB/s] [ > ] 97% ETA 0:00:00
65536+0 records out
33554432 bytes (34 MB) copied, 4.09045 s, 8.2 MB/s
32MB 0:00:04 [ 7.8MB/s] [ >] 100%
65536+0 records in
65536+0 records out
33554432 bytes (34 MB) copied, 6.93111 s, 4.8 MB/s
resize2fs 1.42.9 (4-Feb-2014)
resize2fs: Bad magic number in super-block while trying to open /dev/sdbl
Couldn't find valid filesystem superblock.

[Fusing modules.img]

umount: /dev/sdb6: not mounted

29864+0 records in

29864+0 records out

15290368 bytes (15 MB) copied, 0.0488528 s, 313 MB/s

14.6MB 0:00:00 [ 299MB/s] [ >] 100%
20864+0 records in

29864+0 records out

15290368 bytes (15 MB) copied, 1.44288 s, 10.6 MB/s
resize2fs 1.42.9 (4-Feb-2014)

Resizing the filesystem on /dev/sdb6 to 5119 (4k) blocks.
The filesystem on /dev/sdb6 is now 5119 blocks long.




Raspberry Pi3 downloader, version 0.1

Device: /dev/sdb
Fusing binary:
tizen-unified 20170814.1 common-iot core-2parts-armv7l-rpi3.tar.gz

ramdisk.img
rootfs.img
system-data.img

[Fusing ramdisk.img]

umount: /dev/sdb7: not mounted

1433640 records in

14336+0 records out

7340032 bytes (7.3 MB) copied, 0.0141529 s, 519 MB/s
7MB 0:00:00 [ 495MB/s] [

Screen when loT Headless Image is installed.*

>] 100%

1433640 records in

14336+0 records out

7340032 bytes (7.3 MB) copied, 0.616807 s, 11.9 MB/s
resize2fs 1.42.9 (4-Feb-2014)

Resizing the filesystem on /dev/sdb7 to 8188 (1lk) blocks.
The filesystem on /dev/sdb7 is now 8188 blocks long.

[Fusing rootfs.img]
umount: /dev/sdb2: not mounted

> ] 93% ETA 0:00:00

297704+0 records in@kB/s] [
207704+0 records out
152424448 bytes (152 MB) copied, 6.17764 s, 24.7 MB/s

145MB 0:00:06 [23.5MB/s] [
0+2193 records in
0+2193 records out
152424448 bytes (152 MB) copied, 13.5183 s, 11.3 MB/s
resize2fs 1.42.9 (4-Feb-2014)
Resizing the filesystem on /dev/sdb2 to 786432 (4k) blocks.
The filesystem on /dev/sdb2 is now 786432 blocks long.

[Fusing system-data.img]
umount: /dewv/sdb3: not mounted

130952+0 records 1in

130952+0 records out

67047424 bytes (67 MB) copied, 0.780652 s, 85.9 MB/s
63.9MB 0:00:00 [81.8MB/s] [

>] 100%

>] 100%

0+919 records in

04919 records out

67047424 bytes (67 MB) copied, 5.95975 s, 11.3 MB/s
resize2fs 1.42.9 (4-Feb-2014)

Resizing the filesystem on /dev/sdb3 to 131072 (4k) blocks.
The filesystem on /dev/sdb3 is now 131872 blocks long.



SOSCON

Booting the RPi3

Connecting a Host PC to RPi3 via UART

)
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Bootingthe RPi3 SOSCON

1. Inserting SD Card to RPi3.

2. Connecting a Host PC to RPi3 via UART Board.
3. Connecting power to RPi3.

4. Entering user ID and password




Booting the RPi3 SOSCON

1. Inserting SD Card to RPi3.
2. Connecting a Host PC to RPi3 via UART Board.

Raspberry Pi 3
o 5oRy

Host PC
(Window)

Serial Port
(PL2303)

1) Information of connecting to UART Board*



SOSCON

1) Information of connecting to UART Board*

In case of PL2303,
RPi3 TXD(08pin) — UART Board RXD
RPi3 RXD(10pin) — UART Board TXD
RPi3 Ground(06pint) — UART Board GND



Booting the RPi3 SOSCON

1. Inserting SD Card to RPi3.
2. Connecting a Host PC to RPi3 via UART Board.

Raspberry Pi 3

Host PC
(Window)

Serial Port
(PL2303)

2) Opening a Serial Terminal with Host PC(Windows) *

Use PUTTY program in practice.



2) Opening a Serial Terminal with Host PC(Windows)*

1. Install the appropriate drivers.

Download the PL2303 Windows Driver : http://www prolific.com.tw/US/ShowProduct.aspx?p id=225&pcid=41
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When the serial port is recognized:

Prolific USB-to-Serial Comm Port (COM#)


http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=225&pcid=41

2) Opening a Serial Terminal with Host PC(Windows)*

1. Execute a PUTTY program to open serial terminal.
Download the PUuTTY terminal emulator : http://www.putty.org/

SOSCON

#R PUTTY Configuration
Category:

[ Session
Logging

- Teminal

- Keyboard

- Bell

- Features

= Window

- Appearance

- Behaviour

- Translation

- Selection

- Colours

[=- Connection

.- Data

- Prowy

- Telnet

- Rlogin

- SSH

- Serial

=]

Basic options for your PuTTY session

Specify the destination you want to connect to

About

Senal line Speed
COM10 115200
Connection type:

(D) Raw () Telnet (O Rlogin (©) SSH  §@) Serial

Load, save or delete a stored session
Saved Sessions

Serial
Default Settings Load
Lire:

Close window on exit:

) Aways () Never @ Only on clean exit

Source : https://software.intel.com/en-us/setting-up-serial-terminal- on-system-with-windows

Configure the PUTTY menu as follows:

a. Under Connection type, select Serial.
b. Inthe Serial line field, enter the COM# for your
board, such as COM10.

* Note . Ifyou did not identify your COM# when setting up your
board, navigate to the Device Manager and check for an entry
called USB Serial Port. The COM# is displayed next to the USB
Serial Port entry.

\
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Booting the RPi3 SOSCON

3. Connecting power to RPi3.
4. Entering user ID and password

« User id : root / Password : tizen (The password is not shown when you enter it.)

COM10 - PuTTY
- = s

(=) -5 ]

m




Booting the RPi3 SOSCON

3. Connecting power to RPi3.
4. Entering user ID and password

« User id : root / Password : tizen (The password is not shown when you enter it.)

COM10 - PuTTY =R A=

. If the following screen does not appear,

Make sure

1. The line connecting the RPi3 to the
UART board is misconnected.

2. The UART board is broken.
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Building a Tizen project

- Cloning Tizen repositories
- Building the project with Tizen Studio

)



Prerequisite

1. Downloading the Git.

https://www.git-scm.com/downloads

2. Installing the Tizen Studio.

https://developer.tizen.org/development/tizen-studio/download

SOSCON

@D



Cloning Tizen repositories

SOSCON

Template source code
* position-finder-server

Git path : apps/native/position-finder-server
Branch : template

« position-finder-client

Git path : apps/native/position-finder-client



Cloning Tizen repositories

SOSCON

1)

w
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£
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Access the Tizen Project GIT Repositories.
https://qit.tizen.org/
Searching for position-finder-server.

‘55 index : apps/native/position-finder-server

Domain: Applications; Licenses: Apache-2.0

summary | refs log tree commit  diff
Branch Commit message
master Modify comments
termplate Modify Comments
zzzzz Merge "add web notification feature, but not enabled yet” intc zarie
Age Commit message
4 hours Modify comments ‘HEADl |master| ‘refs,’changes,fs‘!/lu?a?jl‘
19 hours Meodify comments ‘refs{changes}t)z,flM?DZ,'ll

How to clone the repository : apps/native/position-finder-server.*
Running a Git Bash and cloning the Tizen repository.*

How to change the branch of the project.*

Changing the branch of the Tizen Project.*



3) How to clone the repository : apps/native/position-finder-server*

$ git clone <Git address of the repository)
$ git clone git://qgit.tizen.org/apps/native/position-finder-server

https://git.tizen.org/

summary

Branch
master
template
zarie

Age

4 hours

19 hours
19 hours

2 days

7 days

7 days

7 days

10 days
2017-08-03
2017-08-01
[

Index : apps/native/position-finder-server

Domain: Applications; Licenses: Apache-2.0

tree  commit  diff

Commit message
mModify comments
Modify Comments
mMerge "add web notification feature, but not enabled yet” into zarie

Commit message
Modify comments |HEAD| ‘masterl |re‘fslchan esj%?fl_M}'E?}'ll

mModify comments |refs{chan esjﬂz,flM?Dz,!ll

CBOR file in res dir and auto-naming in spec ‘refa{chan 55/91[14469111|

Modify comments about connectivity API ‘rEfsfchanges/DllﬂMZDd[ll

Add API for LED resource to check human behavior |re‘fs,fchan esﬁ3ﬂ43753{1|

Add comments for sensor and connectivity API |reﬁ/chan 95198/143698f1|

Trivial modification ‘refsfchanges/dmﬁﬁdz,’zl

Copy CBOR file from res dir to data dir for protecting crash |refsjchangesfswl43[)89,!1‘
Remove presence API - not working, maybe it'll be deprecated |refa{chan es/52;142152{1|
Merge “Add connectivity APIs for various data types”

Clone

https://git tizen.org/cgit/apps/native/position-finder-server
git//gittizen.org/apps/native/position-finder-server

SOSCON



4) Running a Git Bash and cloning the Tizen repository* SOSCON

Git bash

MINGW64:/d/Template/position-finder-server

$ cd /d/Template/ - 9 $ Cd <THE PATH>
: . Enters the path to download the source code.

tion-finder-server

eceiving cbaect 210 etk s “one. ™\ $ git clone <Git address of the repository)
o R Downloads the repository on your local PC using
the git clone command.

ex) $ gitclone
git://qgit.tizen.org/apps/native/position-finder-
server




5) How to change the branch of the project*

$ git checkout (BRANCH NAME>
$ git checkout template

https://git.tizen.org/

summary

Branch
master
template
zarie

Age

4 hours

19 hours
19 hours

2 days

7 days

7 days

7 days

10 days
2017-08-03
2017-08-01
[

Clone

Index : apps/native/position-finder-server

Domain: Applications; Licenses: Apache-2.0

tree  commit  diff

Commit message
mModify comments
Modify Comments
mMerge "add web notification feature, but not enabled yet” into zarie

Commit message
Modify comments |HEAD| ‘masterl |re‘fslchan esj%?fl_M}'E?}'ll

mModify comments |refs{chan esjﬂz,flM?Dz,!ll

CBOR file in res dir and auto-naming in spec ‘refa{chan 55/91[14469111|

Modify comments about connectivity API ‘rEfsfchanges/DllﬂMZDd[ll

Add API for LED resource to check human behavior |re‘fs,fchan esﬁ3ﬂ43753{1|

Add comments for sensor and connectivity API |reﬁ/chan 95198/143698f1|

Trivial modification ‘refsfchanges/dmﬁﬁdz,’zl

Copy CBOR file from res dir to data dir for protecting crash |refsjchangesfswl43[)89,!1‘
Remove presence API - not working, maybe it'll be deprecated |refa{chan es/52;142152{1|
Merge “Add connectivity APIs for various data types”

https://git tizen.org/cgit/apps/native/position-finder-server
git//gittizen.org/apps/native/position-finder-server

SOSCON



6) Changing the branch of the Tizen Project* SOSCON

Git bash

MINGWE4:/d/Template/position-finder-server

§ cd /d/Template/

n-finder-server

$ cd position-finder-server

d Enter the project.

/d/Template/position-Finder-server $ git checkout (BRANCH NAME>
AR late o temlate from origin Change the branch of the project using the g/t
S checkout command.

/d/Template/position-finder-server

ex) git checkout template



Building the project with Tizen Studio SOSCON

1. Importing the cloned project into Tizen Studio.*

File> Select /mport---

Tizen ) Select Tizen Project > Next

Select Directory / File> Select Root directory

Location) Browse ) Select the path of the cloned project(--- ¥position-finder-server) > Next
Finish

Pan oo

2. Building the project
Project > Build Project (F10)



Import the project into Tizen Studio.*

Pan oo

Finish

1-b.

File> Select Import:--
Tizen ) Select Tizen Project > Next*

Select Directory / File» Select Root directory*
Location) Browse > Select the path of the cloned project(--- Wposition-finder-server) > Next*

1-c.

1-d.

SOSCON

E Import
Select

Impeort Tizen Projects

=1 EEl

N

=1

Select an impert source:

> = General

b [ CiCe=

> = Git

> = Install

» = Run/Debug

[ Tizen
Tizen Project
——

[ Tizen Import Wizard = |5 =]

@ select pirectory / File Select Project

Select a root directory or archive file to search for existing Tizen projects

Tizen Import Wizard

Select projects to import

| = 5]

@ select Project

Select Directory / File

® Root directory Archive file

Location

D:#¥Template#position-finder-server

Project list

¥ Name Location profile Version

| position-find D wearable * |30 v
© More

< Back Finch Cancel

<Back | ors L nsh ) cancel

Next >

Cancel




Building the project with Tizen Studio SOSCON

1. Import the project into Tizen Studio.*

File> Select /mport---

Tizen ) Select Tizen Project > Next

Select Directory / File> Select Root directory

Location) Browse ) Select the path of the cloned project(--- ¥position-finder-server) > Next
Finish

Pan oo

2. Build the project
Project > Build Project (F10)



SOSCON

Running the tizen project on RPi3

- Connecting RPi3 to the network
- Connecting RPi3 to Tizen Studio

)



Connecting RPi3 to the network SOSCON

Connects RPi3 to Wifi* ’ \ (Connects Host PC to Wifi)

TIZEN STUDIO




SOSCON

Connects RPi3 to Wifi *

Raspberry Pi3 He ¢ Connection API Test App

1. Connects a Host PC to RPi3 via UART,
2. Opens the serial terminal of RPi3.
3. Connects Wifi with the wifi_test command.

$ wifi_test

Follow the steps below:

(Input only numbers,)

1. Wi-Fi Init and set callbacks

3. Activate Wi-Fi device

c. Connect (Write AP name/password)

6. Get connection state (Verify the network is connected)
0. Exit

* Note : Youshould not misspell a AP name and password when you
enter it. If you get typo, you have to run it again from the beginning.




Connects RPi3 to Wifi * SOSCON

Raspberry Pi 3

4. Checks the IP address of the connected Wi-Fi on RPi3.
$ ifconfig




Connecting RPi3 to Tizen Studio SOSCON

<3

TIZEN STUDIO

1) Registers RPi3 as a remote device*

>

2) Runs the Tizen projecton RPi3*




1) Registers RPi3 as a remote device* SOSCON

* Note ! Ipaddress of RPi3 (Refer to Connects RPi3 to Wifi¥)
wlang O 2 K] HNING, MULTICAST, -

Tizen Studio no: f:_::j.-. E:‘

1. Adds RPi3 as a remote device.

a. Connection Explorer> Remote Device Manager
b. Scan (scanning remote devices)

If the connection fails,

1. Check if Wifi is disconnected or not.

2. Sets the connection state to ON. 2. Your RPi3 and PC are on the same local network.
1-a. 1-b. 2,
B= Outline Connection E.. » | = O [ Remote Device Manager bt ] Remote Device Manager X
EE E" E - L |
Remote device manager Name | P | Pot | Connect Name | P | ot | Connect

192.168.0.7 new | 19216807 | 26101 |

__E
26101
Cgaopge‘ to ON

192.168.0.25

192.168.0.24

new 192.168.0.24 26101

new ‘ 192.168.0.25

| 26101 ‘ new

ClDSe Scan Close




2) Runs the Tizen project on RPi3*

1. Running the project on RPi3.
Run> RunAs > -

2_ HOW tO Open the She”_ Conne... X 8 Rootst.

=EBEEH-

-

3. How to view logs.

= 0O

New

Push the file

Pull the file

Refresh

Collapse all
Platform Log
Disconnect

Properties

Open shell

Execute dlogutilin the opened shell.
$ dlogutil <LOG_TAG) ex) dlogutil TT

SOSCON

sh-3.2% su
Password:
bash-3.2¢# ]

$su
Password : tizen

* NOTE: The password is not shown when you enter it.
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